aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/go-1.16/go-1.16.13.inc (renamed from recipes-devtools/go-1.16/go-1.16.10.inc)6
-rw-r--r--recipes-devtools/go-1.16/go-binary-native_1.16.10.bb46
-rw-r--r--recipes-devtools/go-1.16/go-cross-canadian_1.16.13.bb (renamed from recipes-devtools/go-1.16/go-cross-canadian_1.16.10.bb)0
-rw-r--r--recipes-devtools/go-1.16/go-cross_1.16.13.bb (renamed from recipes-devtools/go-1.16/go-cross_1.16.10.bb)0
-rw-r--r--recipes-devtools/go-1.16/go-crosssdk_1.16.13.bb (renamed from recipes-devtools/go-1.16/go-crosssdk_1.16.10.bb)0
-rw-r--r--recipes-devtools/go-1.16/go-native_1.16.13.bb (renamed from recipes-devtools/go-1.16/go-native_1.16.10.bb)0
-rw-r--r--recipes-devtools/go-1.16/go-runtime_1.16.13.bb (renamed from recipes-devtools/go-1.16/go-runtime_1.16.10.bb)0
-rw-r--r--recipes-devtools/go-1.16/go_1.16.13.bb (renamed from recipes-devtools/go-1.16/go_1.16.10.bb)0
8 files changed, 2 insertions, 50 deletions
diff --git a/recipes-devtools/go-1.16/go-1.16.10.inc b/recipes-devtools/go-1.16/go-1.16.13.inc
index 7549ffc..6d148f7 100644
--- a/recipes-devtools/go-1.16/go-1.16.10.inc
+++ b/recipes-devtools/go-1.16/go-1.16.13.inc
@@ -1,8 +1,6 @@
require go-common.inc
-GO_BASEVERSION = "1.16"
-PV = "1.16.10"
-FILESEXTRAPATHS:prepend := "${FILE_DIRNAME}/go-${GO_BASEVERSION}:"
+FILESEXTRAPATHS:prepend := "${FILE_DIRNAME}/go-1.16:"
LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
@@ -17,7 +15,7 @@ SRC_URI += "\
file://0008-use-GOBUILDMODE-to-set-buildmode.patch \
file://0009-Revert-cmd-go-make-sure-CC-and-CXX-are-absolute.patch \
"
-SRC_URI[main.sha256sum] = "a905472011585e403d00d2a41de7ced29b8884309d73482a307f689fd0f320b5"
+SRC_URI[main.sha256sum] = "b0926654eaeb01ef43816638f42d7b1681f2d3f41b9559f07735522b7afad41a"
# Upstream don't believe it is a signifiant real world issue and will only
# fix in 1.17 onwards where we can drop this.
diff --git a/recipes-devtools/go-1.16/go-binary-native_1.16.10.bb b/recipes-devtools/go-1.16/go-binary-native_1.16.10.bb
deleted file mode 100644
index 4866c9f..0000000
--- a/recipes-devtools/go-1.16/go-binary-native_1.16.10.bb
+++ /dev/null
@@ -1,46 +0,0 @@
-# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
-
-SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
-HOMEPAGE = " http://golang.org/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
-
-PROVIDES = "go-native"
-
-SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
-SRC_URI[go_linux_amd64.sha256sum] = "414cd18ce1d193769b9e97d2401ad718755ab47816e13b2a1cde203d263b55cf"
-SRC_URI[go_linux_arm64.sha256sum] = "bfe1d4b82626c742b4690a832ca59a21e3d702161556f3c0ed26dffb368927e9"
-
-UPSTREAM_CHECK_URI = "https://golang.org/dl/"
-UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
-
-S = "${WORKDIR}/go"
-
-inherit goarch native
-
-do_compile() {
- :
-}
-
-make_wrapper() {
- rm -f ${D}${bindir}/$1
- cat <<END >${D}${bindir}/$1
-#!/bin/bash
-here=\`dirname \$0\`
-export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
-\$here/../lib/go/bin/$1 "\$@"
-END
- chmod +x ${D}${bindir}/$1
-}
-
-do_install() {
- find ${S} -depth -type d -name testdata -exec rm -rf {} +
-
- install -d ${D}${bindir} ${D}${libdir}/go
- cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
-
- for f in ${S}/bin/*
- do
- make_wrapper `basename $f`
- done
-}
diff --git a/recipes-devtools/go-1.16/go-cross-canadian_1.16.10.bb b/recipes-devtools/go-1.16/go-cross-canadian_1.16.13.bb
index 7ac9449..7ac9449 100644
--- a/recipes-devtools/go-1.16/go-cross-canadian_1.16.10.bb
+++ b/recipes-devtools/go-1.16/go-cross-canadian_1.16.13.bb
diff --git a/recipes-devtools/go-1.16/go-cross_1.16.10.bb b/recipes-devtools/go-1.16/go-cross_1.16.13.bb
index 80b5a03..80b5a03 100644
--- a/recipes-devtools/go-1.16/go-cross_1.16.10.bb
+++ b/recipes-devtools/go-1.16/go-cross_1.16.13.bb
diff --git a/recipes-devtools/go-1.16/go-crosssdk_1.16.10.bb b/recipes-devtools/go-1.16/go-crosssdk_1.16.13.bb
index 1857c8a..1857c8a 100644
--- a/recipes-devtools/go-1.16/go-crosssdk_1.16.10.bb
+++ b/recipes-devtools/go-1.16/go-crosssdk_1.16.13.bb
diff --git a/recipes-devtools/go-1.16/go-native_1.16.10.bb b/recipes-devtools/go-1.16/go-native_1.16.13.bb
index ffe4ef3..ffe4ef3 100644
--- a/recipes-devtools/go-1.16/go-native_1.16.10.bb
+++ b/recipes-devtools/go-1.16/go-native_1.16.13.bb
diff --git a/recipes-devtools/go-1.16/go-runtime_1.16.10.bb b/recipes-devtools/go-1.16/go-runtime_1.16.13.bb
index 63464a1..63464a1 100644
--- a/recipes-devtools/go-1.16/go-runtime_1.16.10.bb
+++ b/recipes-devtools/go-1.16/go-runtime_1.16.13.bb
diff --git a/recipes-devtools/go-1.16/go_1.16.10.bb b/recipes-devtools/go-1.16/go_1.16.13.bb
index 34dc89b..34dc89b 100644
--- a/recipes-devtools/go-1.16/go_1.16.10.bb
+++ b/recipes-devtools/go-1.16/go_1.16.13.bb