aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/postinstp/postinstp_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/postinstp/postinstp_1.0.bb')
-rw-r--r--meta-selftest/recipes-test/postinstp/postinstp_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/postinstp/postinstp_1.0.bb b/meta-selftest/recipes-test/postinstp/postinstp_1.0.bb
new file mode 100644
index 00000000000..a5210b10a02
--- /dev/null
+++ b/meta-selftest/recipes-test/postinstp/postinstp_1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Device formfactor information"
+SECTION = "base"
+LICENSE = "MIT"
+
+RDEPENDS_${PN} = "postinstd"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN} () {
+ if test "x$D" != "x"; then
+ # Need to run on first boot
+ exit 1
+ else
+ if test -e /etc/z-test ; then
+ echo 'success' > /etc/postinstp-test
+ else
+ echo 'fail to install postinstd first!' >&2
+ exit 1
+ fi
+ fi
+}
+