aboutsummaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/postinstt/postinstt_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/postinstt/postinstt_1.0.bb')
-rw-r--r--meta-selftest/recipes-test/postinstt/postinstt_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/postinstt/postinstt_1.0.bb b/meta-selftest/recipes-test/postinstt/postinstt_1.0.bb
new file mode 100644
index 00000000000..25c279b6e2a
--- /dev/null
+++ b/meta-selftest/recipes-test/postinstt/postinstt_1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Device formfactor information"
+SECTION = "base"
+LICENSE = "MIT"
+
+RDEPENDS_${PN} = "postinstp"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN} () {
+ if test "x$D" != "x"; then
+ # Need to run on first boot
+ exit 1
+ else
+ if test -e /etc/postinstp-test ; then
+ echo 'success' > /etc/postinstt-test
+ else
+ echo 'fail to install postinstp first!' >&2
+ exit 1
+ fi
+ fi
+}
+