summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_git.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
index 31761368b72..2960811048e 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
@@ -9,8 +9,8 @@ SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
file://0001-Correctly-install-the-shared-library.patch \
"
-PV = "0.10.0+git${SRCPV}"
-SRCREV = "748891ff8ee524c2d37926c608cd2794f88013f3"
+PV = "0.11.1+git${SRCPV}"
+SRCREV = "434a40babdde57ab405e9a1085a30e9575ea0c92"
S = "${WORKDIR}/git"
@@ -21,7 +21,7 @@ inherit cmake pkgconfig bash-completion distutils3-base
EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
do_install_append_class-native() {
@@ -29,3 +29,8 @@ do_install_append_class-native() {
RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
}
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/createrepo_c \
+ RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
+ rm -rf ${D}/etc
+}