aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-test/hello-dut/hello-dut_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-test/hello-dut/hello-dut_0.1.bb')
-rw-r--r--meta/recipes-test/hello-dut/hello-dut_0.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-test/hello-dut/hello-dut_0.1.bb b/meta/recipes-test/hello-dut/hello-dut_0.1.bb
new file mode 100644
index 00000000000..832b62fa872
--- /dev/null
+++ b/meta/recipes-test/hello-dut/hello-dut_0.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Hello world recipe"
+DESCRIPTION = "test application"
+LICENSE = "CLOSED"
+SRC_URI = "file://hello.c \
+"
+S = "${WORKDIR}"
+do_compile() {
+ ${CC} hello.c -o hello
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 hello ${D}/${bindir}
+}
+