aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README6
-rw-r--r--recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend (renamed from recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bbappend)0
-rw-r--r--recipes-multimedia/v4l2apps/files/openat.patch38
-rw-r--r--recipes-multimedia/v4l2apps/media-ctl_git.bb7
-rw-r--r--recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch39
-rw-r--r--recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb11
6 files changed, 51 insertions, 50 deletions
diff --git a/README b/README
index 33d4bc0..cdafdfc 100644
--- a/README
+++ b/README
@@ -10,14 +10,14 @@ Dependencies
Poky
URI: git://git.yoctoproject.org/poky.git
- branch: danny
+ branch: dylan
revision: HEAD
Building meta-meson
------------------
- git clone -b danny git://git.yoctoproject.org/poky
- git clone -b danny git://git.yoctoproject.org/meta-meson
+ git clone -b dylan git://git.yoctoproject.org/poky
+ git clone -b dylan git://git.yoctoproject.org/meta-meson
. poky/oe-init-build-env
# Be sure to add meta-meson to your bblayers.conf file. For example:
diff --git a/recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bbappend b/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
index 72d991c..72d991c 100644
--- a/recipes-connectivity/wpa-supplicant/wpa-supplicant_1.0.bbappend
+++ b/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
diff --git a/recipes-multimedia/v4l2apps/files/openat.patch b/recipes-multimedia/v4l2apps/files/openat.patch
new file mode 100644
index 0000000..6cbd528
--- /dev/null
+++ b/recipes-multimedia/v4l2apps/files/openat.patch
@@ -0,0 +1,38 @@
+From ac8eb4d8e1c16b907e795da123a032869c77c56f Mon Sep 17 00:00:00 2001
+From: Riku Voipio <riku.voipio@linaro.org>
+Date: Tue, 22 Jan 2013 12:44:48 +0200
+Subject: [PATCH] libv4lsyscall-priv.h: use openat when available
+
+New architectures such as 64-Bit arm build kernels without legacy
+system calls - Such as the the no-at system calls. Thus, use
+SYS_openat whenever it is available.
+
+Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
+Signed-off-by: Mauro Carvalho Chehab <mchehab@redhat.com>
+
+Upstream-status: backport
+---
+ lib/libv4lconvert/libv4lsyscall-priv.h | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/lib/libv4lconvert/libv4lsyscall-priv.h b/lib/libv4lconvert/libv4lsyscall-priv.h
+index 2dac49a..cdd38bc 100644
+--- a/lib/libv4lconvert/libv4lsyscall-priv.h
++++ b/lib/libv4lconvert/libv4lsyscall-priv.h
+@@ -72,8 +72,13 @@ typedef off_t __off_t;
+
+ #ifndef CONFIG_SYS_WRAPPER
+
++#ifdef SYS_openat
++#define SYS_OPEN(file, oflag, mode) \
++ syscall(SYS_openat, AT_FDCWD, (const char *)(file), (int)(oflag), (mode_t)(mode))
++#else
+ #define SYS_OPEN(file, oflag, mode) \
+ syscall(SYS_open, (const char *)(file), (int)(oflag), (mode_t)(mode))
++#endif
+ #define SYS_CLOSE(fd) \
+ syscall(SYS_close, (int)(fd))
+ #define SYS_IOCTL(fd, cmd, arg) \
+--
+1.7.10.4
+
diff --git a/recipes-multimedia/v4l2apps/media-ctl_git.bb b/recipes-multimedia/v4l2apps/media-ctl_git.bb
index d96c1f9..cb3072b 100644
--- a/recipes-multimedia/v4l2apps/media-ctl_git.bb
+++ b/recipes-multimedia/v4l2apps/media-ctl_git.bb
@@ -2,17 +2,18 @@ DESCRIPTION = "Media controller control application"
LICENSE = "LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=d749e86a105281d7a44c2328acebc4b0"
+DEPENDS = "linux-libc-headers"
+
SRC_URI = "git://git.ideasonboard.org/media-ctl.git;protocol=git"
SRCREV = "a6ec4a37028952ffd6e62eb52648cf66248eb519"
PV = "0.0.1"
-PR = "r3"
+PR = "r4"
S = "${WORKDIR}/git"
inherit autotools
-# It needs some kernel definitions only for v4l2, so it isn't machine specific
-EXTRA_OECONF = "--with-kernel-headers=${STAGING_KERNEL_DIR}"
+EXTRA_OECONF = "--with-kernel-headers=${STAGING_EXECPREFIXDIR}"
PACKAGES =+ "libmediactl libv4l2subdev"
FILES_libmediactl = "${libdir}/libmediactl${SOLIBS}"
diff --git a/recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch b/recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch
deleted file mode 100644
index 4b11038..0000000
--- a/recipes-multimedia/v4l2apps/v4l-utils/0001-disable-qv4l2-build.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 1422d4c562660407919fb753dc5f074293b395e5 Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Mon, 16 Jul 2012 12:00:34 +0200
-Subject: [PATCH] disable qv4l2 build
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
----
- utils/Makefile | 15 ---------------
- 1 files changed, 0 insertions(+), 15 deletions(-)
-
-diff --git a/utils/Makefile b/utils/Makefile
-index 014b82d..db74851 100644
---- a/utils/Makefile
-+++ b/utils/Makefile
-@@ -5,21 +5,6 @@ all install:
- $(MAKE) -C $$i $@ || exit 1; \
- done
-
-- # Test whether qmake is installed, and whether it is for qt4.
-- @if which qmake-qt4 >/dev/null 2>&1; then \
-- QMAKE=qmake-qt4; \
-- else \
-- QMAKE=qmake; \
-- fi; \
-- if which $$QMAKE >/dev/null 2>&1; then \
-- if $$QMAKE --version 2>&1 | grep '4\.[0-9][0-9]*\.[0-9][0-9]*' >/dev/null; then \
-- if [ ! -f qv4l2/Makefile ]; then \
-- (cd qv4l2 && $$QMAKE) || exit 1; \
-- fi; \
-- $(MAKE) -C qv4l2 -f Makefile.install $@; \
-- fi \
-- fi
--
- sync-with-kernel:
- $(MAKE) -C keytable $@
- $(MAKE) -C v4l2-dbg $@
---
-1.7.7.6
-
diff --git a/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb b/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb
index ce5c5e1..c00f119 100644
--- a/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb
+++ b/recipes-multimedia/v4l2apps/v4l-utils_0.8.8.bb
@@ -13,7 +13,8 @@ inherit autotools gettext
PROVIDES = "libv4l"
SRC_URI = "git://linuxtv.org/v4l-utils.git;protocol=git \
- "
+ file://openat.patch \
+"
# 54f16ca8183dd8ae8bf4ccc07949795aff0301f5 -> v0.8.8 tag
SRCREV = "0298efdcd1153b8f719b9164548a3f0546f0cb7c"
@@ -22,10 +23,10 @@ S = "${WORKDIR}/git"
EXTRA_OECONF = "--disable-qv4l2 --enable-shared"
do_configure() {
- # autotools_do_configure fails with:
- # | configure.ac:139: error: required file 'build-aux/config.rpath' not found
- autoreconf -vfi
- oe_runconf
+ # autotools_do_configure fails with:
+ # | configure.ac:139: error: required file 'build-aux/config.rpath' not found
+ autoreconf -vfi
+ oe_runconf
}
PACKAGES =+ "rc-keymaps libv4l libv4l-dbg libv4l-dev"