aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/CI_github.yml55
-rw-r--r--README.md5
-rw-r--r--classes/mono.bbclass4
-rw-r--r--conf/layer.conf10
-rw-r--r--recipes-mono/dotnet-helloworld/dotnet-helloworld_1.0.bb4
-rw-r--r--recipes-mono/dotnet/dotnet_6.0.419.bb (renamed from recipes-mono/dotnet/dotnet_7.0.400.bb)14
-rw-r--r--recipes-mono/dotnet/dotnet_8.0.201.bb (renamed from recipes-mono/dotnet/dotnet_6.0.413.bb)15
-rw-r--r--recipes-mono/gtk-sharp/gtk-sharp3_2.99.4.bb2
-rw-r--r--recipes-mono/libgdiplus/libgdiplus-common.inc6
-rw-r--r--recipes-mono/mono-addins/mono-addins-xbuild.inc2
-rw-r--r--recipes-mono/mono-addins/mono-addins.inc2
-rw-r--r--recipes-mono/mono-helloworld/mono-helloworld.inc2
-rw-r--r--recipes-mono/mono-upnp/mono-upnp.inc2
-rw-r--r--recipes-mono/mono/mono-6.12.0.161.inc2
-rw-r--r--recipes-mono/mono/mono-6.xx.inc2
-rw-r--r--recipes-mono/mono/mono-base.inc2
-rw-r--r--recipes-mono/mono/mono-native-6.xx-base.inc10
-rw-r--r--recipes-mono/taglib-sharp/taglib-sharp.inc2
-rw-r--r--recipes-python/python3-pythonnet/python3-pythonnet.bb4
19 files changed, 85 insertions, 60 deletions
diff --git a/.github/workflows/CI_github.yml b/.github/workflows/CI_github.yml
index 7d6030c..497b48a 100644
--- a/.github/workflows/CI_github.yml
+++ b/.github/workflows/CI_github.yml
@@ -17,7 +17,7 @@ jobs:
options: --privileged --platform linux/amd64 -v /dev/net/tun:/dev/net/tun -v /dev/kvm:/dev/kvm
strategy:
matrix:
- dotnet_version: [7.0.400]
+ dotnet_version: [8.0.201, 6.0.419]
mono_version: [6.12.0.182]
branch: [mickledore]
arch: [x86-64, arm, arm64]
@@ -29,7 +29,7 @@ jobs:
BRANCH: ${{ matrix.branch }}
steps:
- name: Checkout meta-mono
- uses: actions/checkout@v3
+ uses: actions/checkout@v4
with:
clean: false
path: ${{ matrix.branch }}/meta-mono
@@ -53,37 +53,44 @@ jobs:
fi
- name: Configuring
run: |
+ rm -f ${BRANCH}/build/conf/local.conf
+ rm -f ${BRANCH}/build/conf/bblayers.conf
. ./${BRANCH}/poky/oe-init-build-env ${BRANCH}/build
- if [[ ! $(grep meta-mono/meta-mono/${BRANCH}/meta-mono conf/bblayers.conf) ]]; then
- echo "BBLAYERS += '$GITHUB_WORKSPACE/${BRANCH}/meta-mono'" >> conf/bblayers.conf
- fi
- if [[ ! $(grep meta-openembedded conf/bblayers.conf) ]]; then
- echo "BBLAYERS += '$GITHUB_WORKSPACE/${BRANCH}/meta-openembedded/meta-oe'" >> conf/bblayers.conf
- fi
- if [[ ! $(grep rm_work conf/local.conf) ]]; then
- echo "INHERIT += ' rm_work '" >> conf/local.conf
- fi
+
+ # Append custom variables for regenerated local.conf and bblayers.conf samples
+ echo "### Starting to configure local.conf and bblayers.conf ###"
+ echo "mono version: $MONO_VERSION"
+ echo "dotnet version: $DOTNET_VERSION"
+
+ echo "BBLAYERS += '$GITHUB_WORKSPACE/${BRANCH}/meta-mono'" >> conf/bblayers.conf
+ echo "BBLAYERS += '$GITHUB_WORKSPACE/${BRANCH}/meta-openembedded/meta-oe'" >> conf/bblayers.conf
+
+ echo "MACHINE=\"qemu${ARCH}\"" >> conf/local.conf
+ echo "DL_DIR=\"$GITHUB_WORKSPACE/downloads\"" >> conf/local.conf
+
+ echo "PREFERRED_VERSION_mono=\"${MONO_VERSION}\"" >> conf/local.conf
+ echo "PREFERRED_VERSION_mono-native=\"${MONO_VERSION}\"" >> conf/local.conf
+
+ echo "PREFERRED_VERSION_dotnet=\"${DOTNET_VERSION}\"" >> conf/local.conf
+ echo "PREFERRED_VERSION_dotnet-native=\"${DOTNET_VERSION}\"" >> conf/local.conf
+
+ echo "INHERIT += \" rm_work \"" >> conf/local.conf
sed -i 's/#IMAGE_CLASSES += "testimage testsdk"/IMAGE_CLASSES += "testimage "/' conf/local.conf
+ - name: Cleaning
+ run: |
+ . ./${BRANCH}/poky/oe-init-build-env ${BRANCH}/build
+ bitbake -c cleanall test-image-mono dotnet dotnet-native
- name: Building
run: |
. ./${BRANCH}/poky/oe-init-build-env ${BRANCH}/build
-
- export BB_ENV_PASSTHROUGH_ADDITIONS="${BB_ENV_PASSTHROUGH_ADDITIONS} PREFERRED_VERSION_mono PREFERRED_VERSION_mono-native"
- export BB_ENV_PASSTHROUGH_ADDITIONS="${BB_ENV_PASSTHROUGH_ADDITIONS} PREFERRED_VERSION_dotnet"
- export BB_ENV_PASSTHROUGH_ADDITIONS="${BB_ENV_PASSTHROUGH_ADDITIONS} MACHINE DL_DIR"
-
- env PREFERRED_VERSION_mono="${MONO_VERSION}" PREFERRED_VERSION_dotnet="${DOTNET_VERSION}" PREFERRED_VERSION_mono-native="${MONO_VERSION}" MACHINE="qemu${ARCH}" DL_DIR="$GITHUB_WORKSPACE/downloads" bitbake -k test-image-mono
+ bitbake -k test-image-mono
- name: Testing
run: |
. ./${BRANCH}/poky/oe-init-build-env ${BRANCH}/build
-
- export BB_ENV_PASSTHROUGH_ADDITIONS="BB_ENV_PASSTHROUGH_ADDITIONS PREFERRED_VERSION_mono PREFERRED_VERSION_mono-native"
- export BB_ENV_PASSTHROUGH_ADDITIONS="${BB_ENV_PASSTHROUGH_ADDITIONS} PREFERRED_VERSION_dotnet"
- export BB_ENV_PASSTHROUGH_ADDITIONS="${BB_ENV_PASSTHROUGH_ADDITIONS} MACHINE DL_DIR"
export TERM=linux
- env PREFERRED_VERSION_mono="${MONO_VERSION}" PREFERRED_VERSION_dotnet="${DOTNET_VERSION}" PREFERRED_VERSION_mono-native="${MONO_VERSION}" MACHINE="qemu${ARCH}" DL_DIR="$GITHUB_WORKSPACE/downloads" bitbake test-image-mono -c testimage
+ bitbake test-image-mono -c testimage
- name: Store artifacts
- uses: actions/upload-artifact@v3
+ uses: actions/upload-artifact@v4
with:
- name: test-image-mono-${{ github.sha }}
+ name: test-image-mono-${{ matrix.branch }}-${{ matrix.mono_version }}-${{ matrix.dotnet_version }}-${{ github.sha }}-${{ matrix.arch }}
path: ./${{ matrix.branch }}/build/tmp/deploy/images/qemu${{ matrix.arch }}/
diff --git a/README.md b/README.md
index 9751ea9..b22ab77 100644
--- a/README.md
+++ b/README.md
@@ -6,8 +6,9 @@ meta-mono is an OpenEmbedded layer that builds dotNet, the mono runtime and mono
| Branch | Support Status* | Status of Build & Tests |
| ------ | --------------- | ----------------------- |
-| mickledore | April 2023 | [![mickledore](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=mickledore&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
-| langdale | October 2022 | [![langdale](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=langdale&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
+| nanbield | May 2024 | [![mickledore](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=nanbield&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
+| mickledore | EOL | [![mickledore](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=mickledore&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
+| langdale | EOL | [![langdale](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=langdale&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
| kirkstone | Long Term Support (minimum Apr. 2024) | [![master](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=kirkstone&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
| honister | EOL | [![honister](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=honister&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
| hardknott | EOL | [![hardknott](https://img.shields.io/github/actions/workflow/status/dynamicdevices/meta-mono/CI_github.yml?branch=hardknott&label=build%20%26%20test)](https://github.com/DynamicDevices/meta-mono/actions/workflows/CI_github.yml) |
diff --git a/classes/mono.bbclass b/classes/mono.bbclass
index 071015a..86da1ba 100644
--- a/classes/mono.bbclass
+++ b/classes/mono.bbclass
@@ -1,8 +1,8 @@
# Class for building C# packages. If your package is all-managed, add
# PACKAGE_ARCH="all"
-DEPENDS:append = " mono-native ca-certificates-native mono"
-RDEPENDS:${PN}:append = " mono"
+DEPENDS += "mono-native ca-certificates-native mono"
+RDEPENDS:${PN} += "mono"
FILES:${PN}:append = " \
${libdir}/mono/*/*.exe \
diff --git a/conf/layer.conf b/conf/layer.conf
index 8fc7308..544300a 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -22,4 +22,12 @@ PREFERRED_VERSION_nuget-native ?= "5.2.0"
PREFERRED_VERSION_msbuild ?= "16.10.1"
PREFERRED_VERSION_msbuild-native ?= "16.10.1"
-LAYERSERIES_COMPAT_mono = "kirkstone langdale mickledore"
+# Suppress TMPDIR [buildpaths] warning
+INSANE_SKIP:mono-dbg += "buildpaths"
+INSANE_SKIP:mono-libs-4.5 += "buildpaths"
+INSANE_SKIP:msbuild += "buildpaths"
+INSANE_SKIP:msbuild-dev += "buildpaths"
+INSANE_SKIP:python3-clr-loader += "buildpaths"
+INSANE_SKIP:python3-pythonnet += "buildpaths"
+
+LAYERSERIES_COMPAT_mono = "kirkstone langdale mickledore nanbield"
diff --git a/recipes-mono/dotnet-helloworld/dotnet-helloworld_1.0.bb b/recipes-mono/dotnet-helloworld/dotnet-helloworld_1.0.bb
index c633365..d54f16b 100644
--- a/recipes-mono/dotnet-helloworld/dotnet-helloworld_1.0.bb
+++ b/recipes-mono/dotnet-helloworld/dotnet-helloworld_1.0.bb
@@ -33,7 +33,9 @@ do_compile () {
dotnet build ${S}/${PN}.csproj --output ${B}/${PN} --configuration release --runtime linux-${SRC_ARCH}
#FIXME: remove the following line. if the lttng-ust conflict is solved
- rm ${B}/${PN}/libcoreclrtraceptprovider.so
+ #FIXME: dotnet 8 doesn't produce libcoreclrtraceptprovider.so for the helloworld applications
+ # When dotnet 6 and 7 reach end of life remove the following line.
+ rm -f ${B}/${PN}/libcoreclrtraceptprovider.so
}
do_install () {
diff --git a/recipes-mono/dotnet/dotnet_7.0.400.bb b/recipes-mono/dotnet/dotnet_6.0.419.bb
index 911ad73..e2f1010 100644
--- a/recipes-mono/dotnet/dotnet_7.0.400.bb
+++ b/recipes-mono/dotnet/dotnet_6.0.419.bb
@@ -19,16 +19,16 @@ RDEPENDS:${PN}:remove:class-native = "libgssapi-krb5"
PR = "r0"
SRC_ARCH:aarch64 = "arm64"
-SRC_FETCH_ID:aarch64 = "16b0b1af-6eab-4f9e-b9a4-9b29f6a1d681/4624e54b61cae05b1025211482f9c5e9"
-SRC_SHA512SUM:aarch64 = "474879abcf40d4a06d54e02997a3fb93dd10c8d5f0dfd5acbf7e1a6f493a6d3421e426431d512b482c62cda92d7cda4eddd8bab80f923d0d2da583edaa8905e8"
+SRC_FETCH_ID:aarch64 = "3b18aefa-0e14-4193-a167-35e1de4cfe46/acf2b230ae3ecfbc4d5f4c20cbf97b2d"
+SRC_SHA512SUM:aarch64 = "c249e5c1d15f040e2e4ce444328ec30dd1097984b1b0c4d48d1beb61c7e35d06f133509500ee63ded86a420e569920809b587ff2abe073da3d8f10d4a03a9d15"
SRC_ARCH:arm = "arm"
-SRC_FETCH_ID:arm = "59aac694-6949-44c1-960b-2b6feca7c36c/d670fb92396fb5bdb0173b9114611841"
-SRC_SHA512SUM:arm = "680641bb807483831fae57c07b635b710be10c1a2791fc98d371cf7417c2f78f187f7542d15177482237ada5a4c874b35318fd0a0f66f0e42bd531048092c1b9"
+SRC_FETCH_ID:arm = "badd7c97-634f-410d-9397-995524372595/3d773584b9017d27433c1fe793d9696f"
+SRC_SHA512SUM:arm = "ebd3795b6b9e828fb6735156d9121c2858fd225559f2ecf93f0c65280e8bc18197249f3244d8d6a6f0cb84d14f9c3718acd01cd5457441c2836aca4101335392"
SRC_ARCH:x86-64 = "x64"
-SRC_FETCH_ID:x86-64 = "dbfe6cc7-dd82-4cec-b267-31ed988b1652/c60ab4793c3714be878abcb9aa834b63"
-SRC_SHA512SUM:x86-64 = "4cfeedb8e99ffd423da7a99159ee3f31535fd142711941b8206542acb6be26638fbd9a184a5d904084ffdbd8362c83b6b2acf9d193b2cd38bf7f061443439e3c"
+SRC_FETCH_ID:x86-64 = "8828b97b-7bfd-4b1b-a646-e55bddc0d7ad/e2f7d168ad273e78fbae72ffb6d215d3"
+SRC_SHA512SUM:x86-64 = "155a9ab33dc11a76502c24b94dbcd188b06e51f56814082f6570fd923cd74b0266baefbcb6becdd34e41c3979f5b21ca333a7fa57f0e41e5435d28e8815d1641"
SRC_URI[vardeps] += "SRC_FETCH_ID SRC_ARCH"
SRC_URI[sha512sum] = "${SRC_SHA512SUM}"
@@ -38,7 +38,7 @@ SRC_URI = "https://download.visualstudio.microsoft.com/download/pr/${SRC_FETCH_I
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-DOTNET_RUNTIME = "7.0.10"
+DOTNET_RUNTIME = "6.0.27"
do_install[vardeps] += "DOTNET_RUNTIME"
do_install() {
diff --git a/recipes-mono/dotnet/dotnet_6.0.413.bb b/recipes-mono/dotnet/dotnet_8.0.201.bb
index 719debd..3728e36 100644
--- a/recipes-mono/dotnet/dotnet_6.0.413.bb
+++ b/recipes-mono/dotnet/dotnet_8.0.201.bb
@@ -19,16 +19,16 @@ RDEPENDS:${PN}:remove:class-native = "libgssapi-krb5"
PR = "r0"
SRC_ARCH:aarch64 = "arm64"
-SRC_FETCH_ID:aarch64 = "82132239-803b-4800-971e-ded613cc280a/67d0025a0a54566657c3e6dfeb90253e"
-SRC_SHA512SUM:aarch64 = "7f05a9774d79e694da5a6115d9916abf87a65e40bd6bdaa5dca1f705795436bc8e764242f7045207386a86732ef5519f60bdb516a3860e4860bca7ee91a21759"
+SRC_FETCH_ID:aarch64 = "3bebb4ec-8bb7-4854-b0a2-064bf50805eb/38e6972473f83f11963245ffd940b396"
+SRC_SHA512SUM:aarch64 = "37e230970cfeffdc3873e42595b79ecdf6bfe266a01ace6953725e69a2b64313ce144bf4d4f861130f61f680ead9b4d8a819dd5543c5470c37bbc13d88a78c80"
SRC_ARCH:arm = "arm"
-SRC_FETCH_ID:arm = "11682594-fb2f-4a01-861c-cc76935003f6/9138dabf011a0c07bc306443dedee687"
-SRC_SHA512SUM:arm = "3268e0d401bb1d6b189b780a5a88502b3a1140c6d9176a98bca0c468839d1a1802f3c89c7559314a79b53a940cf6312caf2f11e494b9d98638f32e437a125e47"
+SRC_FETCH_ID:arm = "2344ad1d-ce80-4d98-bf9c-f935576deb39/591ea75057045e2284a7d70d5dd01bc5"
+SRC_SHA512SUM:arm = "92760c4a4f3bf559daa41b8b87d7f10995aa5ae11783af053d854e8b9e8b042cf6e984bda40490aff051e4463f7cc8ed25d905090e5cee029c81afdb7f8b32c2"
SRC_ARCH:x86-64 = "x64"
-SRC_FETCH_ID:x86-64 = "8eed69b0-0f3a-4d43-a47d-37dd67ece54d/0f2a9e86ff24fbd7bbc129b2c18851fe"
-SRC_SHA512SUM:x86-64 = "ee0a77d54e6d4917be7310ff0abb3bad5525bfb4beb1db0c215e65f64eb46511f5f12d6c7ff465a1d4ab38577e6a1950fde479ee94839c50e627020328a702de"
+SRC_FETCH_ID:x86-64 = "85bcc525-4e9c-471e-9c1d-96259aa1a315/930833ef34f66fe9ee2643b0ba21621a"
+SRC_SHA512SUM:x86-64 = "310cf54f595698435b533931b12f86d49f89d27243cf7c87a5b926e0c676b80e869aa58aaff17b5095536c432f377c67d92bf0ca8941b9d891d4b3879637d488"
SRC_URI[vardeps] += "SRC_FETCH_ID SRC_ARCH"
SRC_URI[sha512sum] = "${SRC_SHA512SUM}"
@@ -38,7 +38,7 @@ SRC_URI = "https://download.visualstudio.microsoft.com/download/pr/${SRC_FETCH_I
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-DOTNET_RUNTIME = "6.0.21"
+DOTNET_RUNTIME = "8.0.2"
do_install[vardeps] += "DOTNET_RUNTIME"
do_install() {
@@ -96,5 +96,6 @@ FILES:${PN}-dbg = "\
RRECOMMENDS:dotnet-dev[nodeprrecs] = "1"
INSANE_SKIP:${PN} = "already-stripped libdir staticdev textrel dev-so"
+INSANE_SKIP:${PN}-dbg = "libdir"
BBCLASSEXTEND = "native"
diff --git a/recipes-mono/gtk-sharp/gtk-sharp3_2.99.4.bb b/recipes-mono/gtk-sharp/gtk-sharp3_2.99.4.bb
index ffcf94f..035f2b9 100644
--- a/recipes-mono/gtk-sharp/gtk-sharp3_2.99.4.bb
+++ b/recipes-mono/gtk-sharp/gtk-sharp3_2.99.4.bb
@@ -8,7 +8,7 @@ RDEPENDS:${PN} += " perl gtk+3"
LIC_FILES_CHKSUM = "file://COPYING;md5=8754deb904d22254188cb67189b87f19"
SRCREV = "9a72bb67fff7e4845b7bb430a608282668c3e4da"
-SRC_URI = "git://github.com/mono/gtk-sharp.git;branch=master \
+SRC_URI = "git://github.com/mono/gtk-sharp.git;protocol=https;branch=master \
file://0001-fixup-gmcs-to-mcs.patch"
S = "${WORKDIR}/git"
diff --git a/recipes-mono/libgdiplus/libgdiplus-common.inc b/recipes-mono/libgdiplus/libgdiplus-common.inc
index c6af811..5ccb7b9 100644
--- a/recipes-mono/libgdiplus/libgdiplus-common.inc
+++ b/recipes-mono/libgdiplus/libgdiplus-common.inc
@@ -7,12 +7,8 @@ LICENSE = "MIT"
BRANCH ?= "main"
-BRANCH_googletest ?= "v1.8.x"
-SRCREV_googletest = "dea0216d0c6bc5e63cf5f6c8651cd268668032ec"
-
SRC_URI = " \
- git://github.com/mono/libgdiplus.git;protocol=https;branch=${BRANCH} \
- gitsm://github.com/google/googletest.git;protocol=https;name=googletest;branch=${BRANCH_googletest};destsuffix=git/external/googletest \
+ gitsm://github.com/mono/libgdiplus.git;protocol=https;branch=${BRANCH} \
"
S = "${WORKDIR}/git"
diff --git a/recipes-mono/mono-addins/mono-addins-xbuild.inc b/recipes-mono/mono-addins/mono-addins-xbuild.inc
index 35ae719..c1f571c 100644
--- a/recipes-mono/mono-addins/mono-addins-xbuild.inc
+++ b/recipes-mono/mono-addins/mono-addins-xbuild.inc
@@ -11,7 +11,7 @@ DEPENDS = "mono"
SRCREV = "64a45d96f39d4714ec85adf0fe04b68ec7273ae1"
SRCBRANCH = "master"
-SRC_URI = "git://github.com/mono/mono-addins.git;branch=${SRCBRANCH}"
+SRC_URI = "git://github.com/mono/mono-addins.git;protocol=https;branch=${SRCBRANCH}"
S = "${WORKDIR}/git"
diff --git a/recipes-mono/mono-addins/mono-addins.inc b/recipes-mono/mono-addins/mono-addins.inc
index 084a60c..2044068 100644
--- a/recipes-mono/mono-addins/mono-addins.inc
+++ b/recipes-mono/mono-addins/mono-addins.inc
@@ -11,7 +11,7 @@ DEPENDS = "gtk-sharp"
SRCREV = "64a45d96f39d4714ec85adf0fe04b68ec7273ae1"
SRCBRANCH = "master"
-SRC_URI = "git://github.com/mono/mono-addins.git;branch=${SRCBRANCH} \
+SRC_URI = "git://github.com/mono/mono-addins.git;protocol=https;branch=${SRCBRANCH} \
file://0001-configure-mcs.patch"
S = "${WORKDIR}/git"
diff --git a/recipes-mono/mono-helloworld/mono-helloworld.inc b/recipes-mono/mono-helloworld/mono-helloworld.inc
index 14be73e..b693d4c 100644
--- a/recipes-mono/mono-helloworld/mono-helloworld.inc
+++ b/recipes-mono/mono-helloworld/mono-helloworld.inc
@@ -4,7 +4,7 @@ AUTHOR = "Alex J Lennon <ajlennon@dynamicdevices.co.uk>"
HOMEPAGE = "http://www.dynamicdevices.co.uk"
SECTION = "mono/applications"
PRIORITY = "optional"
-LICENSE = "GPLv3"
+LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://LICENSE;md5=783b7e40cdfb4a1344d15b1f7081af66"
SRC_URI = "https://github.com/DynamicDevices/mono-helloworld/releases/download/v${PV}/mono-helloworld-${PV}.tar.gz"
diff --git a/recipes-mono/mono-upnp/mono-upnp.inc b/recipes-mono/mono-upnp/mono-upnp.inc
index 461e14a..5750946 100644
--- a/recipes-mono/mono-upnp/mono-upnp.inc
+++ b/recipes-mono/mono-upnp/mono-upnp.inc
@@ -13,7 +13,7 @@ SRCBRANCH = "master"
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}-${PV}:"
-SRC_URI = "git://github.com/mono/mono-upnp.git;branch=${SRCBRANCH} \
+SRC_URI = "git://github.com/mono/mono-upnp.git;protocol=https;branch=${SRCBRANCH} \
"
S = "${WORKDIR}/git"
diff --git a/recipes-mono/mono/mono-6.12.0.161.inc b/recipes-mono/mono/mono-6.12.0.161.inc
index 9e2fb0f..265f212 100644
--- a/recipes-mono/mono/mono-6.12.0.161.inc
+++ b/recipes-mono/mono/mono-6.12.0.161.inc
@@ -3,7 +3,7 @@ SRC_URI[sha256sum] = "29c277660fc5e7513107aee1cbf8c5057c9370a4cdfeda2fc781be6986
S = "${WORKDIR}/mono-${BASEPV}"
-DEPENDS += " cmake-native"
+DEPENDS += "cmake-native"
do_configure:prepend () {
sed -i 's/${BASEPV}/${PV}/g' configure.ac
diff --git a/recipes-mono/mono/mono-6.xx.inc b/recipes-mono/mono/mono-6.xx.inc
index 29ab350..355cd9d 100644
--- a/recipes-mono/mono/mono-6.xx.inc
+++ b/recipes-mono/mono/mono-6.xx.inc
@@ -4,7 +4,7 @@ HOMEPAGE = "http://mono-project.com"
BUGTRACKER = "http://bugzilla.xamarin.com/"
SECTION = "devel"
-DEPENDS = "zlib libatomic-ops"
+DEPENDS += "zlib libatomic-ops"
SRC_URI = "http://download.mono-project.com/sources/mono/mono-${PV}.tar.xz \
file://dllmap-config.in.diff \
diff --git a/recipes-mono/mono/mono-base.inc b/recipes-mono/mono/mono-base.inc
index c0e66e3..1a5a1f8 100644
--- a/recipes-mono/mono/mono-base.inc
+++ b/recipes-mono/mono/mono-base.inc
@@ -1,4 +1,4 @@
-DEPENDS = "mono-native"
+DEPENDS += "mono-native"
EXTRA_OECONF += " --disable-mcs-build mono_cv_clang=no "
diff --git a/recipes-mono/mono/mono-native-6.xx-base.inc b/recipes-mono/mono/mono-native-6.xx-base.inc
index 695030c..ee0eda0 100644
--- a/recipes-mono/mono/mono-native-6.xx-base.inc
+++ b/recipes-mono/mono/mono-native-6.xx-base.inc
@@ -23,3 +23,13 @@ do_populate_sysroot[postfuncs] += " mono_copy_libdir_mono "
do_install:append() {
sed "s|\$mono_libdir|${libdir}|g" -i ${D}${sysconfdir}/mono/config
}
+
+# Adding BBCLASSEXTEND = "native" here allows recipes including this
+# file to have their dependenvies adjusted automatically. This is
+# required for example when compiling msbuild-native, which depends on
+# mono-native (but must not depend on mono).
+#
+# Ideally, we would only declare BBCLASSEXTEND = "native" in a main
+# recipe for mono and let bitbake generate a -native version of the
+# recipe automatically.
+BBCLASSEXTEND = "native"
diff --git a/recipes-mono/taglib-sharp/taglib-sharp.inc b/recipes-mono/taglib-sharp/taglib-sharp.inc
index 4349ba6..909312e 100644
--- a/recipes-mono/taglib-sharp/taglib-sharp.inc
+++ b/recipes-mono/taglib-sharp/taglib-sharp.inc
@@ -8,7 +8,7 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
DEPENDS = "mono"
-SRC_URI = "git://github.com/mono/taglib-sharp.git;branch=${SRCBRANCH}"
+SRC_URI = "git://github.com/mono/taglib-sharp.git;protocol=https;branch=${SRCBRANCH}"
S = "${WORKDIR}/git"
diff --git a/recipes-python/python3-pythonnet/python3-pythonnet.bb b/recipes-python/python3-pythonnet/python3-pythonnet.bb
index 8971ffd..77f545a 100644
--- a/recipes-python/python3-pythonnet/python3-pythonnet.bb
+++ b/recipes-python/python3-pythonnet/python3-pythonnet.bb
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = " \
inherit pypi python_flit_core
-PV = "3.0.2"
-SRC_URI[sha256sum] = "2cdd1ccedc64a7c9bd711be3d0fd0c4a78932474139dc54aa697bedde741c746"
+PV = "3.0.3"
+SRC_URI[sha256sum] = "8d4b2e97158a023875f8647458a58f38817f4fe39af60abdd6b0d8adf1d77e75"
PYPI_PACKAGE = "pythonnet"
DOTNET_MIN_REQ_VERSION ?= "6.0.0"